Namely Payroll Step 1 Issues
Incident Report for Namely Site
Resolved
This incident has been resolved.
Posted Dec 10, 2019 - 14:08 EST
Investigating
We are investigating reports of degraded performance in Namely Payroll, where administrators are not able to get to step 1 of a pay cycle.
Posted Dec 10, 2019 - 13:59 EST