Degraded Performance
Incident Report for Namely Site
Resolved
We have resolved the issue that was preventing some clients from approving pay cycles due today. We have extended the payroll deadline for cycles due today to 6:00 PM EST.
Posted Dec 03, 2021 - 17:05 EST
Update
We are continuing to investigate this issue.
Posted Dec 03, 2021 - 16:45 EST
Investigating
We're investigating an issue that is preventing some clients from approving pay cycles due today.
Posted Dec 03, 2021 - 16:44 EST
This incident affected: Namely Services.