Namely Time Outage
Incident Report for Namely Site
Resolved
The incident has been resolved and system behavior should resume as expected.
Posted Mar 05, 2021 - 13:26 EST
Update
We are still investigating this issue and will provide another update soon.
Posted Mar 05, 2021 - 11:59 EST
Update
We are continuing to investigate this issue and will provide an update soon.
Posted Mar 05, 2021 - 10:39 EST
Investigating
We are currently investigating an outage in Namely Time, which is preventing employees and administrators from logging in. We will provide an update shortly.
Posted Mar 05, 2021 - 10:03 EST
This incident affected: Namely Services.