W-2 Latency in Namely Payroll
Incident Report for Namely Site
Resolved
This incident has been resolved, and system behavior should resume as expected.
Posted Jan 22, 2020 - 11:29 EST
Investigating
Namely is currently investigating an issue impacting accessibility of employee W-2s.
Posted Jan 22, 2020 - 09:59 EST
This incident affected: Namely Services.