Adobe eSignature
Incident Report for Namely Site
Resolved
Namely has confirmed that Adobe eSignature has returned to normal operation.
Posted over 1 year ago. Jun 11, 2018 - 13:36 EDT
Investigating
Namely is currently investigating intermittent outages with Adobe eSignature.
Posted over 1 year ago. Jun 11, 2018 - 10:19 EDT