Adobe eSignature

Incident Report for Namely Site

Resolved

This incident has been resolved.
Posted May 22, 2023 - 09:09 EDT

Identified

Namely is being affected by the current Adobe eSignature incident. We are in contact with Adobe's team and will provide updates as they become available. For more information, please visit https://status.adobe.com/ and select Issue #202305160033.
Posted May 16, 2023 - 11:54 EDT
This incident affected: Namely Services.