Employee Tax Page Outages
Incident Report for Namely Site
Resolved
The outage on the Employee Tax Page has been resolved as of 12:05 PM ET.
Posted 3 months ago. Jun 24, 2019 - 12:06 EDT
Update
We are still working to address the outage on the Employee Tax Page affecting employees without tax records.
Posted 3 months ago. Jun 24, 2019 - 11:50 EDT
Identified
We are currently working to address an outage on the Employee Tax Page affecting employees without tax records.
Posted 3 months ago. Jun 24, 2019 - 10:50 EDT
Investigating
Namely is investigating reports of outages impacting the Employee Tax Page.
Posted 3 months ago. Jun 24, 2019 - 10:22 EDT
This incident affected: Namely Services.