HCM Slowness

Incident Report for Namely Site

Resolved

This incident has been resolved.
Posted Nov 15, 2019 - 16:06 EST

Update

We are continuing to investigate this issue.
Posted Nov 15, 2019 - 15:33 EST

Update

We are continuing to investigate this issue.
Posted Nov 15, 2019 - 15:27 EST

Investigating

Namely is investigating degraded performance impacting HCM, where users may experience site slowness.
Posted Nov 15, 2019 - 15:27 EST