Namely Timesheets Approval Issue
Incident Report for Namely Site
Resolved
This incident has been resolved, and system behavior should resume as expected.
Posted Mar 22, 2021 - 12:12 EDT
Update
We are continuing to investigate this issue and will provide another update soon.
Posted Mar 22, 2021 - 11:48 EDT
Investigating
We are currently investigating reports of degraded performance in Namely Timesheets, where certain admins are unable to approve employee timesheets. We will provide an update shortly.
Posted Mar 22, 2021 - 11:21 EDT
This incident affected: Namely Services.