Namely Payroll Not Loading
Incident Report for Namely Site
Resolved
The incident above has been resolved, and system behavior should resume as expected.
Posted Jul 21, 2020 - 17:46 EDT
Investigating
We are currently investigating reports of Namely Payroll not loading. We will provide an update shortly.
Posted Jul 21, 2020 - 17:42 EDT
This incident affected: Namely Services.