E-Verify Not Accepting Passports as Identification Method
Incident Report for Namely Site
Resolved
We have confirmed that E-Verify is now operating as expected.
Posted Apr 19, 2022 - 14:41 EDT
Update
We are continuing to investigate this issue.
Posted Apr 12, 2022 - 14:50 EDT
Investigating
E-Verify is currently experiencing an issue impacting the ability to submit cases using a passport as a form of identification. This issue requires work on the E-Verify side of our integration, and they are actively working to resolve it as quickly as possible.

Until a fix is implemented, you can use other forms of accepted identification to submit your case. If this is not possible, E-Verify has assured us that there will be no liability on your part for any late submissions. When you are able to submit your case, you can select "Technical Issues" as a late filing reason.

We will provide an update once E-Verify has confirmed they've resolved the issue.
Posted Apr 08, 2022 - 12:02 EDT
This incident affected: Namely Services.