Uploading Additional Pay Issues
Incident Report for Namely Site
Resolved
The incident has been resolved and system behavior has resumed as expected.
Posted Feb 08, 2021 - 10:12 EST
Investigating
We are investigating reports of clients experiencing issues when uploading additional pay. We will provide an update shortly.
Posted Feb 08, 2021 - 09:47 EST
This incident affected: Namely Services.