Site-wide Access Issues
Incident Report for Namely Site
Resolved
This incident has been resolved
Posted Apr 11, 2022 - 15:39 EDT
Investigating
We are currently investigating an issue preventing access to Namely across the site.
Posted Apr 11, 2022 - 15:27 EDT
This incident affected: Namely Services.