Multi-EIN Payroll Access
Incident Report for Namely Site
Resolved
This incident has been resolved.
Posted Feb 04, 2022 - 09:03 EST
Investigating
We are currently investigating issues preventing users from logging into multiple Payroll Companies.
Posted Feb 03, 2022 - 16:47 EST
This incident affected: Namely Services.