Namely Time Login Issues
Incident Report for Namely Site
Resolved
We have confirmed the impact preventing users from logging into Namely Time (Powered by Time Clock Plus) is limited to international employees and will be working with those clients directly to resolve.
Posted Oct 04, 2021 - 15:58 EDT
Identified
We have identified the issue impacting Namely Time (powered by Time Clock Plus) that is preventing some employees and administrators from logging in. If you are unable to log in, please contact the Time Clock Plus support team and they will work with you to resolve the issue. They can be reached at 325-223-9300 and ChannelPartner@TCPSoftware.com.
Posted Sep 24, 2021 - 16:58 EDT
Investigating
We are currently investigating an outage in Namely Time, which is preventing employees and administrators from logging in. We will provide an update shortly.
Posted Sep 24, 2021 - 12:28 EDT
This incident affected: Namely Services.