Namely Payroll Degraded Performance
Incident Report for Namely Site
Resolved
The incident has been resolved and site behavior should resume as expected.
Posted Aug 04, 2021 - 12:01 EDT
Monitoring
We are monitoring degraded performance within Namely Payroll. If you experience session timeouts or lag during calculations, please try again.
Posted Aug 04, 2021 - 11:27 EDT
This incident affected: Namely Services.