Intermittent E-Verify Outages
Incident Report for Namely Site
Resolved
This incident has been resolved.
Posted Sep 22, 2022 - 09:58 EDT
Identified
We have confirmed that sporadic outages at E-Verify may be impacting some clients' ability to access existing and submit new E-Verify cases. If you are experiencing issues, please refresh your browser's cookies and try again.
Posted Sep 21, 2022 - 15:55 EDT
Investigating
We are investigating reports of intermittent outages in E-Verify.
Posted Sep 21, 2022 - 12:28 EDT
This incident affected: Namely Services.