Namely Timesheets Error
Incident Report for Namely Site
Resolved
The issue above has been resolved, and system behavior should resume as expected.
Posted Jan 28, 2020 - 10:24 EST
Investigating
Namely is currently investigating issues where Administrators are not able to approve time in Namely Timesheets.
Posted Jan 28, 2020 - 10:05 EST
This incident affected: Namely Services.