We are currently working to resolve an issue reported in benefits administration.
Incident Report for Namely
Resolved
Benefits Administration issues are now resolved as of 2/28/18 at 4:10pm ET.
Posted 12 months ago. Feb 28, 2018 - 16:10 EST
Update
Benefits Administration has been restored. We are currently working to resolve issues reported in benefits reflecting in Namely that occurred since the fix.
Posted 12 months ago. Feb 28, 2018 - 12:48 EST
Identified
We are currently working to resolve an issue reported in benefits administration; the benefits administration module is temporarily unavailable. We will provide an update as soon as the system is online. We anticipate that will occur within the hour.
Posted 12 months ago. Feb 28, 2018 - 12:12 EST