e-signatures

Incident Report for Namely Site

Resolved

This incident has been resolved.
Posted Oct 20, 2023 - 12:25 EDT

Investigating

Some customers have reported receiving error messages when sending eSignature documents to employees. Our engineering team is investigating and actively working to resolve the issue.
Posted Oct 20, 2023 - 09:48 EDT
This incident affected: Namely Services.