Namely Payroll Slowness
Incident Report for Namely Site
Resolved
This incident has been resolved, and we are continuing to monitor that system behavior has resumed as expected in Namely Payroll.
Posted Dec 30, 2019 - 14:48 EST
Update
We are actively investigating this issue, and will provide another update shortly.
Posted Dec 30, 2019 - 13:40 EST
Update
We are continuing to investigate this issue, and will provide further updates shortly.
Posted Dec 30, 2019 - 13:22 EST
Update
We are continuing to investigate this issue.
Posted Dec 30, 2019 - 13:03 EST
Investigating
We are investigating reports of site slowness in Namely Payroll, and will provide further updates shortly.
Posted Dec 30, 2019 - 13:03 EST
This incident affected: Namely Services.