Payroll Preview Reports
Incident Report for Namely Site
Resolved
This incident has been resolved.
Posted Sep 27, 2021 - 11:03 EDT
Investigating
Namely is investigating reports of degraded performance using Preview Reports in Step 3 of payroll processing in Namely Payroll.
Posted Sep 27, 2021 - 10:13 EDT
This incident affected: Namely Services.