E-Verify Access
Incident Report for Namely Site
Resolved
E-Verify is functioning as expected.
Posted Feb 25, 2022 - 15:55 EST
Monitoring
E-Verify access is operational and we are closely monitoring to ensure the connection is fully functioning.
Posted Feb 25, 2022 - 15:06 EST
Investigating
We are currently investigating an issue that is impacting users from accessing or using E-Verify services from Namely.
Posted Feb 25, 2022 - 12:30 EST
This incident affected: Namely Services.