Payroll & Benefits Outages
Incident Report for Namely
Resolved
All outages impacting Payroll and Benefits have been resolved as of 2:14 PM ET.
Posted 5 months ago. Feb 26, 2019 - 14:14 EST
Investigating
Namely is investigating reports of outages impacting Namely Payroll and Benefits.
Posted 5 months ago. Feb 26, 2019 - 13:50 EST
This incident affected: Namely Services.