Namely Time Outage
Incident Report for Namely Site
Resolved
The incident has been resolved, and system behavior should resume as expected.
Posted Mar 09, 2021 - 21:55 EST
Investigating
We are currently investigating an outage in Namely Time, which is preventing employees and administrators from logging in. We will provide an update shortly.
Posted Mar 09, 2021 - 20:23 EST
This incident affected: Namely Services.