Benefits Enrollment Reports
Incident Report for Namely Site
Resolved
This incident has been resolved, and system behavior should resume as expected.
Posted Sep 24, 2020 - 17:06 EDT
Update
We are continuing to investigate this issue and will provide another update soon.
Posted Sep 24, 2020 - 16:25 EDT
Investigating
We have received reports of degraded performance in Benefit Enrollment Reports, where blank reports are being generated. We will provide further updates shortly.
Posted Sep 24, 2020 - 15:37 EDT
This incident affected: Namely Services.