Namely is investigating reports of intermittent slowness in the platform.
Incident Report for Namely
Resolved
All reports of intermittent slowness in the platform are now resolved as of 3/5/2018 11:32 am ET
Posted over 1 year ago. Mar 05, 2018 - 11:32 EST
Investigating
Namely is investigating reports of intermittent slowness in the platform.
Posted over 1 year ago. Mar 05, 2018 - 11:14 EST