Namely Payroll Slowness
Incident Report for Namely Site
Resolved
Site performance of Namely Payroll should resume as expected.
Posted Nov 19, 2019 - 13:20 EST
Investigating
We are currently working to address reports of degraded site performance in Namely Payroll.
Posted Nov 19, 2019 - 13:09 EST