Payroll processing Delays
Incident Report for Namely
Resolved
The earlier incident causing extended wait times for payroll processing has been resolved. All payroll have been processed.
Posted 12 months ago. Feb 23, 2018 - 14:27 EST
Investigating
We were experiencing slowdowns in payroll processing starting from 1:25 PM ET resulting in extended wait times for calculation.
Posted 12 months ago. Feb 23, 2018 - 14:13 EST